حل مشكلة الاضاءة في أوبونتو 10.10 و 11.04

هناك مشكلة في الكيرنل الموجودة في اوبونتو 11.04 و ما قبلها ، حيث لا يستطيع بعض المستخدمين في بعض الاجهزة من تغيير اضاءة الشاشة عبر لوحة المفاتيح او خلال برنامج التحكم الخاص بالاضاءة .

المهندس كمال مصطفى في كانونيكال تمكن من حل هذه المشكلة ، منذ اشهر ، و لكن حتى الان لم يتم الموافقة على الحل في المنبع “النواة” مع انه المفترض ان يكون الحل كاملا موجود في النواة 2.6.39 ، لذلك قام بتخصيص مستودع خاص به النواة الخاصة باوبونتو و مرفق معها الحل .

قبل اكمال الموضوع طبق الامر التالي في الطرفية لتعرف انك المقصود بالحل :

lsmod | grep ^i915

يجب ان يكون الناتج يبدا بـ i915  ما عدا ذلك ها الحل ليس لك .

لتثبيت المستودع :

sudo add-apt-repository ppa:kamalmostafa/linux-kamal-mjgbacklight

sudo apt-get update

لتثبيت النواة المعدلة لاوبونتو 11.04 وهي نفس النواة الموجودة حاليا ورقمها : 2.6.38-9

sudo apt-get install linux-headers-2.6.38-9 linux-headers-2.6.38-9-generic linux-image-2.6.38-9-generic --fix-missing

لتثبيت النواة المعدلة لاوبونتو 10.10 وهي نفس النواة الموجودة في اوبونتو 10.10 : ورقمها 2.6.35-29

sudo apt-get install linux-headers-2.6.35-29 linux-headers-2.6.35-29-generic linux-image-2.6.35-29-generic --fix-missing

اعد التشغيل و ادخل بالنواة الحديثة .

لم اجرب المستودع لانى لا اواجه هذه المشكلة .

لمزيد من التفاصيل و التبليغ عن المشاكل :

https://launchpad.net/~kamalmostafa/+archive/linux-kamal-mjgbacklight

6 Responses to حل مشكلة الاضاءة في أوبونتو 10.10 و 11.04

  1. عبدالله العنزي قال:

    الله يبارك فيك اخي الكريم ثعلب عمان

    • foxoman قال:

      الله يبارك فيك🙂

  2. قرقشني قال:

    اخوي ثعلب عمان أنا طبقت الأمر lsmod | grep ^i915
    ولكن لم يخرج شي؟

    • foxoman قال:

      حسب ملاحظات المهندس صاحب الحل ، انه اذا لم يطلع لك شي بعد تطبيق الامر معناه انك تعاني من مشكلة اخرى وهذا الحل لن يفيدك .

      لكن بصراحة ماعرف اقوله سوى تجرب اذا تحب تخاطر🙂

  3. ابو فيصل قال:

    السلام عليكم
    ثعلب عمان
    طال عمرك انا عندي مشكلة في الكمبيز
    كل ما اعيد تشغيل الجهاز يعلق ولا يشتغل الكمبيز
    ومرات وانا اشتغل يطفي الكميز ولا يشتغل الا في هذا الامر compiz –replace
    وصراحه انا حطيت الامر هذا compiz –replace في بداية التشغيل ولا نفع لا اروح للترمينال واضيف عشان يشتغل الكمبيز
    علما ان توزيعتي اوبنتيو 10,10
    وشاكر لك
    انتظر رد ان شاء الله

    • foxoman قال:

      وعليكم السلام اخي العزيز ،،

      حاول تثبيت ايقونة fusion-icon

      وضعها عند بداية التشغيل .

أضف تعليقاً

إملأ الحقول أدناه بالمعلومات المناسبة أو إضغط على إحدى الأيقونات لتسجيل الدخول:

WordPress.com Logo

أنت تعلق بإستخدام حساب WordPress.com. تسجيل خروج   / تغيير )

صورة تويتر

أنت تعلق بإستخدام حساب Twitter. تسجيل خروج   / تغيير )

Facebook photo

أنت تعلق بإستخدام حساب Facebook. تسجيل خروج   / تغيير )

Google+ photo

أنت تعلق بإستخدام حساب Google+. تسجيل خروج   / تغيير )

Connecting to %s

%d مدونون معجبون بهذه: